[debian] td-agentのインストール

■openssl0.9.8が必要

wget http://ftp.us.debian.org/debian/pool/main/o/openssl/libssl0.9.8_0.9.8o-4squeeze14_amd64.deb

dpkg -i libssl0.9.8_0.9.8o-4squeeze14_amd64.deb

■fluent-plugin-elasticsearchを使うときに必要

apt-get install libcurl4-gnutls-dev

 

wget http://packages.treasure-data.com/debian/pool/contrib/td-agent/td-agent_1.1.19-1_amd64.deb

※最新版があるかもしれないので確認

dpkg -i td-agent_1.1.19-1_amd64.deb

 

■プラグインを探す。

gem search -rd fluent-plugin

■プラグイン追加

/usr/lib/fluent/ruby/bin/fluent-gem install fluentd

/usr/lib/fluent/ruby/bin/fluent-gem install fluent-plugin-multiprocess

/usr/lib/fluent/ruby/bin/fluent-gem install fluent-plugin-elasticsearch

 

 

■マルチプロセスで待ち受ける設定

 

 

 

 

 

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です