kvmゲストに入れたjessieにvirsh consoleでアクセスする

# インストール終了直後の初回再起動時のこの画面で「e」キーを押す

+—————————————————————————-+
|*Debian GNU/Linux |
| Advanced options for Debian GNU/Linux |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
+—————————————————————————-+

# 「linux」行の末尾に「console=ttyS0,115200n8」を追記して「Ctrl + x」キーを押す

+—————————————————————————————+
| search –no-floppy –fs-uuid –set=root 82c9915f-4b67-46cc-ac63-c6dd4d7662d1|
| |
| else |
| search –no-floppy –fs-uuid –set=root 82c9915f-4b67-46cc-ac63-c6dd4d7662d1 |
| |
| fi |
| echo ‘Loading Linux 3.16.0-4-amd64 …’ |
| linux /vmlinuz-3.16.0-4-amd64 root=/dev/mapper/debian–vg-root ro quiet\|
| console=ttyS0,115200n8 |
| echo ‘Loading initial ramdisk …’ |
| initrd /initrd.img-3.16.0-4-amd64 |

起動後以下のコマンドでサービスを有効にする。
systemctl enable getty@ttyS0

[debian] td-agentのインストール

■openssl0.9.8が必要

wget http://ftp.us.debian.org/debian/pool/main/o/openssl/libssl0.9.8_0.9.8o-4squeeze14_amd64.deb

dpkg -i libssl0.9.8_0.9.8o-4squeeze14_amd64.deb

■fluent-plugin-elasticsearchを使うときに必要

apt-get install libcurl4-gnutls-dev

 

wget http://packages.treasure-data.com/debian/pool/contrib/td-agent/td-agent_1.1.19-1_amd64.deb

※最新版があるかもしれないので確認

dpkg -i td-agent_1.1.19-1_amd64.deb

 

■プラグインを探す。

gem search -rd fluent-plugin

■プラグイン追加

/usr/lib/fluent/ruby/bin/fluent-gem install fluentd

/usr/lib/fluent/ruby/bin/fluent-gem install fluent-plugin-multiprocess

/usr/lib/fluent/ruby/bin/fluent-gem install fluent-plugin-elasticsearch

 

 

■マルチプロセスで待ち受ける設定

 

 

 

 

 

debianへDell OMSAのインストール

libssl0.9.8が必要

wget http://snapshot.debian.org/archive/debian/20110406T213352Z/pool/main/o/openssl098/libssl0.9.8_0.9.8o-7_amd64.deb

dpkg -i  libssl0.9.8_0.9.8o-7_amd64.deb

 

1. (Optional for Upgrade) Create a new file ending in ‘sources.list’ in the ‘/etc/apt/sources.list.d’ directory. Cut and paste the command below. (If typing by hand, note carefully the spacing.)

echo ‘deb http://linux.dell.com/repo/community/deb/latest /’ | tee -a /etc/apt/sources.list.d/linux.dell.com.sources.list

2. To verify OMSA packages, add the repository key to apt. Note that you must re-do this step if upgrading from OMSA 6.5 because a new key is being used.

gpg –keyserver pool.sks-keyservers.net –recv-key 1285491434D8786F

gpg -a –export 1285491434D8786F | apt-key add –

If you are behind a firewall that only allows outbound traffic over port 80, you may need to use this instead:

gpg –keyserver hkp://pool.sks-keyservers.net:80 –recv-key 1285491434D8786F (possibly needing to add “–keyserver-options http-proxy=http://<user>:<password>@<proxy>:<port>”)

gpg -a –export 1285491434D8786F | sudo apt-key add –

3. Make apt aware of the new software repository by issuing the following command:

apt-get update

apt-get install srvadmin-all

service dsm_om_connsvc start

update-rc.d dsm_om_connsvc defaults

 

ln -s /opt/dell/srvadmin/bin/omreport /usr/bin/omreport

◆ サーバの正常性確認
# omreport system esmlog

# omreport system alertlog

# omreport chassis

# omreport storage controller controller=X

# omreport storage controller
Controllers
ID : 0

 

[KVM]KVMゲストOSへのコンソール接続設定

ゲストOSがDebian GNU/Linux 6.0の場合

# vi /etc/inittab
T0:23:respawn:/sbin/getty -L ttyS0 9600 vt100  

# vi /etc/default/grub
GRUB_CMDLINE_LINUX="console=tty0"  

# update-grub

ゲストOSがubuntu の場合

  • # vi /etc/init/ttyS0.conf 
    start on stopped rc RUNLEVEL=[2345]
    stop on runlevel [!2345]
    
    respawn
    exec /sbin/getty -L 115200 ttyS0 vt102
    
  • # start ttyS0
    
  • # vi /etc/default/grub
    GRUB_CMDLINE_LINUX="console=tty0 console=ttyS0,115200n8" 
    GRUB_TERMINAL=serial  
    GRUB_SERIAL_COMMAND="serial --speed=115200 --unit=0 --word=8 --parity=no --stop=1" 

    Sの場合

 

 

debian squeezeからwheezyへのアップデート

①/etc/apt/sources.listを修正

deb http://ftp.debian.org/debian/ wheezy main contrib
deb-src http://ftp.debian.org/debian/ wheezy main contrib

deb http://security.debian.org/ wheezy/updates main
deb-src http://security.debian.org/ wheezy/updates main

②wheezyで利用可能なパッケージリストを取得

sudo apt-get update

③新しいパッケージと依存関係に問題がないか(競合状態にならないか)確認
sudo apt-get upgrade

④システムのアップグレード

apt-get dist-upgrade

⑤再起動

[kvm]debianでKVMセットアップ

aptitude install kvm libvert-bin bridge-utils virt-manager pm-utils
ネットワーク仮想化のオーバーヘッドを減らすことができる vhost-net を有効に
#modprobe vhost_net
#lsmod | grep vhost
 vhost_net     27606 0

#echo vhost_net >> /etc/modules
Nested KVMを有効にするための設定を行う。
# cat /sys/module/kvm_intel/parameters/nested
N

# vi /etc/modprobe.d/kvm-nested.conf
options kvm_intel nested=1

# modprobe -r kvm_intel
# modprobe kvm_intel

# cat /sys/module/kvm_intel/parameters/nested

Y
-------------------------
bonding設定

apt-get install ifenslave -y

#cat /etc/modules
bonding
# cat /etc/modprobe.d/bonding
options bonding mode=1 miimon=200
------------
root以外のユーザーがさわれるように

adduser ${user} libvirt